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Introduction

Welcome to this tutorial on the world's most powerful container stowage tool - Angelstow.

After completing the tutorial you should be able to use the key features of the software. Angelstow 
is here to help you save time and money in your daily operation. The unique features of this tool  
assist you in preventing expensive situations like excessive restows or extended port stays. 
Angelstow should allow you to get a better overview of the stowages, be able to focus on the 
important details, and to plan better stowages faster.

Do remember, that even if it is powerful, Angelstow is only a tool. In designing it, we have accepted
that you - the user - will always be the better judge at what is the best stowage plan. Angelstow 
makes mistakes from time to time, but we try very hard to keep its decisions transparent, and to 
make sure that it provides you with ways to overrule its decisions. You are in charge, not the tool.

Angelstow is constantly being improved. If you find that something is missing, or if you have an 
idea for making Angelstow better, let us know! Send an email to stow@ange.dk with your feedback.

Installing Angelstow on your Windows PC

Double-click on the downloaded Angelstow executable file. A regular Windows installation 
dialogue appears. Follow the on-screen instructions to install Angelstow.

Opening a stowage document

After installation, Angelstow can be opened using the Start menu. Choose All programs -> 
Angelstow 0.24.x -> Angelstow 0.24.x

Getting started with Angelstow can be done in 2 ways: By opening a vessel profile or by opening a 
so-called Stowage Document (a file ending with  .sto).

When opening a vessel profile, a Stowage Document (SD) is automatically created with an empty 
schedule and empty cargo lists.

For the purpose of this tutorial download and open the SD that came with the tutorial. In the 
Angelstow window, choose File -> Open and select the file you received that has extension “.sto”.

The file contains a vessel profile, a schedule, an actual loadlist for the current port (CNNGB) and 
estimated loadlists for some subsequent ports. 

You are now ready to stow the vessel.

Stowing Dangerous Goods

The first step of the stowage will be to place special cargo, specifically DG.

Make sure CNNGB is the current port, either by clicking on it in the schedule panel or on the 
schedule ribbon at the left of the master scan plan view.
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Now we have to find the DGs in the load list, which is done using a recap. If you don't have a recap 
panel available, click View->Add Recap. In the recap, right click  in the upper left corner and 
choose Filters -> Clear, and then Filters ->Availability. This will show you which cargo is currently 
available for loading “in the yard”.  By right-clicking in the recap, make sure that you are able to 
select DG cargo for specific PODs. One possible layout of the recap is illustrated in the figure 
below.

Select the DG containers and place them on the vessel using the magic wand  tool: Click on the 
magic wand icon, select some containers in the recap, then "paint" them onto the vessel with the 
mouse. As you place some of the containers, IMO segregation rules might cause some positions to 
be unavailable for other containers. This is indicated by the concerned slots being grayed out like in 
the figure below

At the end of this tutorial you will find an appendix explaining the recap panel in more detail.
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Recap showing POD on the vertical axis and POL, DG type
and container length horizontally

The IMO class 2.1 container can be placed 
on deck, but not adjacently to the class 3.0 
under deck.



Master Planning

Once the special cargo has been placed, it is time to place the normal cargo. In Angelstow, this is 
done mainly using so-called Master Planning, consisting of assigning compartments to each POD 
(Port Of Discharge). 

Using master planning this way, you only have to decide on the high-level (per-hatch) layout and 
may let the computer handle the specific placement of each container.

Switching to master planning mode is done by clicking the “Macro plan” button. Below is an 
example of a bay being macrostowed.

Decide which POD you would like to stow containers for as the first one. Select a bay to be loaded 
with containers for that POD. 

Then assign your POD to each compartment.

Select more bays and compartments and assign your POD to these. When you feel that sufficient 
space has been allocated, run master planning by clicking the “Master Plan” button.
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The "Master Plan" button calculates the optimal placement for each container, such as to:
• maximize stack height utilization under deck (HC/DC mix)
• maximize stack weight utilization under deck

while respecting:
• the user-provided POD-assignment
• reefers are placed in reefer slots
• the user-provided weight limits (explained below)
• stack limits on height and weight.

You can freely assign different PODs to bays and compartments. Whenever you want to see a 
stowage, press the "Master Plan" button. Keep going until all containers to be loaded in the current 
call have been stowed. Don't worry if individual containers need to be rearranged, for example to 
respect windstack limits. This type of decision will be addressed below in the section "Refining 
with microstowage".

When all containers on the load list of the current call have been placed, you may choose to carry 
out the master planning process for the next call. Besides creating a good starting point for your 
next stowage, macrostowing the next call has two important advantages:

• Quality assurance of the stowage for the current call. The master planning may reveal a 
downstream problem, for example extended port stay caused by too many moves in adjacent
bays.

• Documentation of the intended use of bays downstream. This may be useful to as personal 
notes as well as a means for explaining the vessel's current stowage to others.

You may macrostow any number of future load ports until you are satisfied that the stowage in the 
current port is of high quality. To macrostow a future load call, its load list needs to be estimated. If 
no booking estimate is available, the COPRAR for a call to the same port on the same service is 
often a reasonable approximation.

Checking the crane split

During the master planning, the user should keep an eye on the crane split diagrams. These indicate 
whether or not the stowage will live up to the agreed proforma productivity / proforma crane 
intensity.
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The diagram below describes the crane activities, in a call where the cranes need to be separated by 
a 40' bay and are able to twin lift 20' containers.

The vertical bars describe the activity in each bay. The red part of a bar represents load moves while
the blue part of the bar represents discharge moves. The vertical bar in the middle of each bay 
describes 40' activity. The two bars on each side of the middle one describe 20' activity fore and aft. 
The accomodation is marked with a thin vertical blue line.

The dashed horizontal green line in the top indicates the average number of moves per crane.

The horizontal grey lines have a special meaning: when cranes need to be separated by a 40' bay the
following rule applies:

“If the sum of the activities in two adjacent bays 

exceeds the average number of moves per crane,

there will be a long crane equalling the exceeding amount”

Each of the discreet, horizontal, grey lines represents the sum of activities in two adjacent bays. 
When this sum exceeds the green dashed line, the grey line turns red. This alerts you to the fact that 
the current plan will not achieve the proforma productivity. The activity in the two bays marked by 
the red line will cause one of the cranes to prolong the operation. Unless delayed port stay is not an 
issue, you should try to distribute load moves from the two bays into other sections of the vessel.

A similar rule applies for 80' crane separation.

Tuning the Master Plan with weight controls

In order to minimize the use of ballast, you can control the cargo weight distribution created by 
master planning by limiting the number of tonnes allowed in each bay. The weight limit controls are
integrated with the stresses graph. This graph is viewed by clicking View->Panels -> Stresses.

Setting a weight limit is done by right-clicking in the graph and choosing "Limit bay xx". The 
weight limit can subsequently be modified by dragging the limit arrow vertically.

The example below shows a stresses graph with weight limits:
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Refining with microstowage

Once the master planning has been carried out and the planner is satisfied with the high-level result,
it is time to polish the details. For instance, master planning currently leaves lashing and windstack 
limits for you to handle.  
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Initial bending problem

Limiting the weight in the extremeties causes a redistribution of the cargo weight. This solves the 
bending problem.



In the example below, notice the 45' containers on deck. Each 45' container is marked with a black 
"5" in its top right corner (the white number in the middle of a container is its weight). Some of 
these have been stacked too low and need to be raised above the lashing bridge. 

To achieve this, use the magic wand tool again: Click on the magic wand icon, select some 
containers in the recap, then use the mount as a brush to place them at exact slots on the vessel.
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Before microstowing: 45' containers stowed too low on deck



Master planning will try to keep the cargo in as few stacks as possible in order to keep bottom space
available. You may want to redistribute the top containers in some of the over deck compartments 
using microstowage.

Keyboard modifiers when selecting containers
When selecting containers, the standard selection tool (Select or Magic) will only select containers 
loaded / restowed in the current port.

In order to select Remaining On Boards, the Ctrl key has to be pressed on the keyboard.
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After microstowing: 40' containers have been added to lift the 45' above the 
lashing bridge



Pressing the Shift key allows to assemble multiple selections of containers.

Autoballasting

Finally, the vessel needs to be ballasted to safisfy stress limits, stability constraints and  listing  and 
trim criteria. This is done using the autoballast function. Simply enter the desired trim and click 
“Run” (listing will be set to 0).

Exporting the result and sending it to the terminal

When the stowage is ready the result can be exported as a MOVINS, BAPLIE, scanplans, and lists 
of special cargo. This is done using the different  File -> Export ... functions.

Done!

You've created your first Angelstow stowage plan. There are many features that we haven't 
presented here. We hope that you will explore Angelstow and try them out. If you want to know 
more, we're here to help. Write directly to the Angelstow team at stow@ange.dk with your 
questions, comments, and feedback. We're looking forward to hearing from you.
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Appendix: Using the Recap

Each recap is a 2-dimensional table allowing to easily group, search and select containers, along the
idea of a pivot table.

It is structured around 

• Filters that allow the user to filter out the containers that are irrelevant for his current task, 
e.g. only consider "available for load" or "traversing" (explained below).

 

• Aggregator fields defining which dimensions the container list should be aggregated along 
(e.g. split in 20/40, rounded weight). A detailed list of aggregators is found below. 

Filters

The available filters are: 

• Available for load. This is the most common filter, giving the planner an overview of the 
containers remaining to be loaded. 

• Traversing. This filters away the containers that are irrelevant for the current port, i.e. that 
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Aggregator fields



were discharged before or loaded after. 

• IMO only. Only show dangerous goods.

• None. No filtering means that all containers in the stowage document are shown 

• Aggregator fields. All the aggregator fields can also be used as filters, i.e. the user can 
choose to see e.g. only "20ft" or "reefers". 

The filters are chosen by right-clicking in the upper left corner of the recap and choosing the 
appropriate filters. Note: multiple filters can be applied at the same time, however only the first one 
is shown in the filter area. 

Aggregators

The different aggregator fields are: 

• 20/40 : split (or aggregate) on container length 

• MTY : split/aggregate on empty/full condition 

• DC/HC : split/aggregate on container height 

• DG : split/aggregate on IMO type 

• Rounded Weights : split/aggregate container weight 

• Reefer : split/aggregate on live reefer condition 

• POD : split/aggregate on POD 

• Stowed: split/aggregate according to stowage status, i.e. on-board, on the yard, 
macro-stowed and micro-stowed.

To display the details of one of the aggregation fields (for instance vertically), right-click in one of 
the left-most columns and select the relevant field. 
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Showing containers as a list

In the context menu of the recap (obtained by right-clicking), the user is offered to option to display
the recap as a list.
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